avro-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "W.P. McNeill" <bill...@gmail.com>
Subject How do I get the Avro 1.5.3 Jars when build.sh gives "svn: '.' is not a working copy" error
Date Tue, 06 Sep 2011 22:10:30 GMT
I want to use the latest (1.5.3) version of Avro. I downloaded the
avro-src-1.5.3.tar.gz tarball from the Avro webpage and tried to build it
with the "build.sh dist" command but saw the following error:


> ./build.sh dist
+ for target in '"$@"'
+ case "$target" in
+ mvn enforcer:enforce -Davro.version=1.5.3
[INFO] Scanning for projects...
[INFO]
------------------------------------------------------------------------
[INFO] Building Apache Avro Toplevel
[INFO]    task-segment: [enforcer:enforce]
[INFO]
------------------------------------------------------------------------
[INFO] [enforcer:enforce {execution: default-cli}]
[INFO]
------------------------------------------------------------------------
[INFO] BUILD SUCCESSFUL
[INFO]
------------------------------------------------------------------------
[INFO] Total time: < 1 second
[INFO] Finished at: Tue Sep 06 15:05:17 PDT 2011
[INFO] Final Memory: 9M/150M
[INFO]
------------------------------------------------------------------------
+ mkdir -p build
+ SRC_DIR=avro-src-1.5.3
+ rm -rf build/avro-src-1.5.3
+ svn export --force . build/avro-src-1.5.3
svn: '.' is not a working copy


>From this email
exchange<http://search-hadoop.com/m/e4jfm1atErs&subj=Re+VOTE+Avro+release+1+5+1+rc+0+>it
appears that this is a known issue, but I couldn't find it in the JIRA
database and I don't know what the workaround is.

How do I get the 1.5.3 Avro JAR files?

Mime
View raw message