avro-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Hansen <dsche...@gmail.com>
Subject Avro ruby gem 1.3.3 md5 issues with 1.9
Date Thu, 15 Sep 2011 15:34:11 GMT
I tried installing Avro with ruby last night and kept getting an error
that it requires 'md5'.  As of ruby-1.9 I think you have to require
'digest/md5' instead of 'md5' and a quick google search took me to
JIRA avro-787 which makes it look to me like this was fixed.  However
as best I can tell, that was for version 1.5.0 and the gem that's
available on rubygems is still back at version 1.3.3 -- Is there a
later release that's 1.9 compatible which is also stable?  If so, is
it packaged and distributed somewhere?  Or do I have to install it
from the source.  If not, do I just have to stick with Ruby 1.8.7 for
Avro?

Thanks!
Jeff

Mime
View raw message