avro-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremy Hinegardner <jer...@hinegardner.org>
Subject Re: Avro ruby gem 1.3.3 md5 issues with 1.9
Date Fri, 16 Sep 2011 06:34:31 GMT
On Thu, Sep 15, 2011 at 10:34:11AM -0500, Jeff Hansen wrote:
> I tried installing Avro with ruby last night and kept getting an error
> that it requires 'md5'.  As of ruby-1.9 I think you have to require
> 'digest/md5' instead of 'md5' and a quick google search took me to
> JIRA avro-787 which makes it look to me like this was fixed.  However
> as best I can tell, that was for version 1.5.0 and the gem that's
> available on rubygems is still back at version 1.3.3 -- Is there a
> later release that's 1.9 compatible which is also stable?  If so, is
> it packaged and distributed somewhere?  Or do I have to install it
> from the source.  If not, do I just have to stick with Ruby 1.8.7 for
> Avro?

It looks like the gem is created as part of the build, but it is not pushed to
rubygems.  http://www.apache.org/dist/avro/avro-1.5.4/ruby/

I sent an email jmhodges who is the owner of avro on rubygems asking if he was
going to keep it up to date with releases from apache. Unfortunately I have yet
to hear back. 

If anyone can get a hold of Jeff Hodges and have him coordinate with the avro
release team that would be most helpful.

enjoy,

-jeremy

-- 
========================================================================
 Jeremy Hinegardner                              jeremy@hinegardner.org 


Mime
View raw message