avro-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arto Bendiken <arto.bendi...@gmail.com>
Subject Ruby gem packaging & distribution
Date Mon, 16 Aug 2010 07:27:46 GMT
I'd like to ask if whoever is in charge of the Ruby packaging of Avro
would be so kind as to upload the missing latest releases (1.3.1,
1.3.2, 1.3.3) to RubyGems.org:

  http://rubygems.org/gems/avro

At present, anybody installing the Ruby implementation using `gem
install avro` will be obtaining the 1.3.0 release, which has issues
that manually installing the 1.3.3 release fixed for me.

Also, without new releases being pushed to RubyGems.org as a matter of
course, it is not possible for users to effectively add a dependency
on the Avro gem. Suppose I wanted to publish a Ruby library "foobar"
that depended on avro >= 1.3.3; when my users attempted to install my
gem with `gem install foobar`, the installation would fail since the
Avro dependency could not be resolved and obtained, not being
registered with RubyGems.org. This state of affairs is certain to
adversely affect uptake of Avro amongst the Ruby community.

In case nobody is currently in charge of the Ruby packaging, I'd be
happy to contribute where I can.

Best regards,
Arto

-- 
Arto Bendiken | http://ar.to/

Mime
View raw message