avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jorge Perez (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AVRO-2085) Cant Import avro.schema from pip install python 3.6
Date Sun, 01 Oct 2017 03:19:00 GMT

     [ https://issues.apache.org/jira/browse/AVRO-2085?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jorge Perez updated AVRO-2085:
------------------------------
    Description: 
I tried importing avro.schema, and I receive the error posted below but I made a pull request
that solves that issue. https://github.com/apache/avro/pull/253


{code:java}
(gavro) [gavro] python                                                                   
                                22:11:37 
Python 3.6.2 (default, Jul 20 2017, 03:52:27) 
[GCC 7.1.1 20170630] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import avro
>>> import avro.schema
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/home/archangel/VENV/gavro/lib/python3.6/site-packages/avro/schema.py", line 340
    except Exception, e:
                    ^
SyntaxError: invalid syntax
>>> 
(gavro) [gavro] pip freeze | ack avro                                                    
                                22:12:01 
avro==1.8.2

{code}


  was:
I tried importing avro.schema, and I receive the error posted below but I made a pull request
that solves that issue. https://github.com/apache/avro/pull/253


{code:python}
(gavro) [gavro] python                                                                   
                                22:11:37 
Python 3.6.2 (default, Jul 20 2017, 03:52:27) 
[GCC 7.1.1 20170630] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import avro
>>> import avro.schema
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/home/archangel/VENV/gavro/lib/python3.6/site-packages/avro/schema.py", line 340
    except Exception, e:
                    ^
SyntaxError: invalid syntax
>>> 
(gavro) [gavro] pip freeze | ack avro                                                    
                                22:12:01 
avro==1.8.2

{code}



> Cant Import avro.schema from pip install python 3.6
> ---------------------------------------------------
>
>                 Key: AVRO-2085
>                 URL: https://issues.apache.org/jira/browse/AVRO-2085
>             Project: Avro
>          Issue Type: Bug
>          Components: python
>    Affects Versions: 1.8.2
>            Reporter: Jorge Perez
>
> I tried importing avro.schema, and I receive the error posted below but I made a pull
request that solves that issue. https://github.com/apache/avro/pull/253
> {code:java}
> (gavro) [gavro] python                                                              
                                     22:11:37 
> Python 3.6.2 (default, Jul 20 2017, 03:52:27) 
> [GCC 7.1.1 20170630] on linux
> Type "help", "copyright", "credits" or "license" for more information.
> >>> import avro
> >>> import avro.schema
> Traceback (most recent call last):
>   File "<stdin>", line 1, in <module>
>   File "/home/archangel/VENV/gavro/lib/python3.6/site-packages/avro/schema.py", line
340
>     except Exception, e:
>                     ^
> SyntaxError: invalid syntax
> >>> 
> (gavro) [gavro] pip freeze | ack avro                                               
                                     22:12:01 
> avro==1.8.2
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message