avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Suraj Acharya (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AVRO-2055) Remove Magic Value From org.apache.avro.hadoop.io.AvroSequenceFile
Date Fri, 21 Jul 2017 05:43:00 GMT

    [ https://issues.apache.org/jira/browse/AVRO-2055?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16095810#comment-16095810
] 

Suraj Acharya commented on AVRO-2055:
-------------------------------------

+1.
LGTM

> Remove Magic Value From org.apache.avro.hadoop.io.AvroSequenceFile
> ------------------------------------------------------------------
>
>                 Key: AVRO-2055
>                 URL: https://issues.apache.org/jira/browse/AVRO-2055
>             Project: Avro
>          Issue Type: Improvement
>          Components: java
>    Affects Versions: 1.7.7, 1.8.2
>            Reporter: BELUGA BEHR
>            Assignee: BELUGA BEHR
>            Priority: Trivial
>         Attachments: AVRO-2055.1.patch
>
>
> Remove magic string _io.file.buffer.size_ and _DEFAULT_BUFFER_SIZE_BYTES_ and instead
rely on the Hadoop libraries to provide this information.  Will help to keep Avro in sync
with changes in Hadoop.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message