avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AVRO-1956) C sharp build fails in docker image
Date Thu, 10 Nov 2016 15:14:58 GMT

    [ https://issues.apache.org/jira/browse/AVRO-1956?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15654298#comment-15654298
] 

ASF GitHub Bot commented on AVRO-1956:
--------------------------------------

GitHub user nielsbasjes opened a pull request:

    https://github.com/apache/avro/pull/153

    AVRO-1956 Workaround incompatibility in testing CSharp code

    I'm not quite sure this is the right solution direction.
    An alternative would be to verify if the 'missing component is installed or not.

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/nielsbasjes/avro AVRO-1956

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/avro/pull/153.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #153
    
----
commit 3fd8ffd668e5a58b98c1e9de80e7ef5d29460197
Author: Niels Basjes <nbasjes@bol.com>
Date:   2016-11-10T15:13:17Z

    AVRO-1956 Workaround incompatibility in testing CSharp code depending on environment

----


> C sharp build fails in docker image
> -----------------------------------
>
>                 Key: AVRO-1956
>                 URL: https://issues.apache.org/jira/browse/AVRO-1956
>             Project: Avro
>          Issue Type: Bug
>            Reporter: Niels Basjes
>            Assignee: Niels Basjes
>
> When you run the build in the centos docker image you get 
> {quote}
> Unhandled Exception:
> System.ArgumentException: NUnit components for version 2.0.50727 of the CLR are not installed
> {quote}
> As noted by [~Simon24601] in the mailing list:
> {quote}
> From discussion with [~jcustenborder], it seems like the C# tests won't run
> on a Mac if we keep the --framework=4.0 in this line; removing it (as has
> been done for 1.8.2) makes the tests run. But removing it makes the tests
> fail on my system (CentOS 7).
> {quote}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message