avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AVRO-1900) build.sh test fails for dev-tools.jar
Date Sat, 10 Sep 2016 23:45:20 GMT

    [ https://issues.apache.org/jira/browse/AVRO-1900?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15480651#comment-15480651
] 

ASF GitHub Bot commented on AVRO-1900:
--------------------------------------

GitHub user rdblue opened a pull request:

    https://github.com/apache/avro/pull/122

    AVRO-1900: Remove dev-tools to fix Java build.

    The dev-tools module has to be built before working in lang/java. This
    breaks the build.sh script and is a confusing failure for new Java
    contributors. This commit fixes the problem by moving the checkstyle
    config back into the lang/java/pom.xml. It is applied to all Java
    modules under lang/java.

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/rdblue/avro AVRO-1900-fix-java-build

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/avro/pull/122.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #122
    
----
commit 52e005ed22c5d07cb7f9da404449bf95853b34fe
Author: Ryan Blue <blue@apache.org>
Date:   2016-09-10T23:41:58Z

    AVRO-1900: Remove dev-tools to fix Java build.
    
    The dev-tools module has to be built before working in lang/java. This
    breaks the build.sh script and is a confusing failure for new Java
    contributors. This commit fixes the problem by moving the checkstyle
    config back into the lang/java/pom.xml. It is applied to all Java
    modules under lang/java.

----


> build.sh test fails for dev-tools.jar
> -------------------------------------
>
>                 Key: AVRO-1900
>                 URL: https://issues.apache.org/jira/browse/AVRO-1900
>             Project: Avro
>          Issue Type: Bug
>    Affects Versions: 1.9.0
>            Reporter: Suraj Acharya
>            Assignee: Suraj Acharya
>              Labels: build
>         Attachments: AVRO-1900.patch
>
>
> When i ran {{./build.sh test}} in the docker container I was getting an error mentioning
dev-tools.jar was not present.
> When I looked further into it I realized that {{build.sh}} never actually builds dev-tools.jar.
> I added a line in the test option to first {{mvn install}} on the dev-tools folder. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message