avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ryan Blue <rb...@netflix.com.INVALID>
Subject Re: verifying the build instructions
Date Wed, 03 Aug 2016 16:41:09 GMT
Sorry about this, I ran into it the last time and forgot to fix the problem.

The addition of the dev-tools Java module (AVRO-1838) to run checkstyle
isn't compatible with our current script. I think the easiest thing to do
is to revert the changes that added the module and instead patch the
original checkstyle rules. To get the 1.8.1 release out, I just reverted
the dev-tools module since it only affected the build.

rb

On Wed, Aug 3, 2016 at 6:55 AM, Sean Busbey <busbey@cloudera.com> wrote:

> This weekend I tried getting my ASF release machine to do a full
> build, in prep for a 1.8 RC. I followed the instructions in BUILD.txt
> to use docker to handle the dependencies.
>
> Once I was in the docker shell, I tried both `./build.sh test` and
> `./build.sh dist` and both failed while trying to build the java
> language libraries due to an unsatisfied dependency on
> org.apache.avro:dev-tools.
>
> Anyone know if this is more likely to be an error in my setup vs a gap
> in the build script? My intuition says gap in the build script, but I
> haven't had time to dig in at all.
>
> --
> busbey
>



-- 
Ryan Blue
Software Engineer
Netflix

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message