avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Kleppmann (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AVRO-1775) Running unit tests on Ruby 2.2
Date Tue, 19 Jan 2016 22:32:40 GMT

     [ https://issues.apache.org/jira/browse/AVRO-1775?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Martin Kleppmann updated AVRO-1775:
-----------------------------------
       Resolution: Fixed
    Fix Version/s: 1.8.0
           Status: Resolved  (was: Patch Available)

Thanks for checking. I've committed this.

We can address the test failures on a separate issue. I tried installing 1.8.7 just now but
couldn't even get it to work. It's [been EOL for 2.5 years|https://www.ruby-lang.org/en/news/2013/06/30/we-retire-1-8-7/]
so I'd vote for retiring support for Ruby 1.8 anyway.

> Running unit tests on Ruby 2.2
> ------------------------------
>
>                 Key: AVRO-1775
>                 URL: https://issues.apache.org/jira/browse/AVRO-1775
>             Project: Avro
>          Issue Type: Bug
>          Components: ruby
>            Reporter: Martin Kleppmann
>             Fix For: 1.8.0
>
>         Attachments: AVRO-1775-1.patch
>
>
> Ruby 2.2 [removed the test/unit framework from the standard library|https://bugs.ruby-lang.org/issues/9711#note-12].
As the Avro Ruby implementation uses it for its tests, we need to add a dependency on the
{{test-unit}} gem in order to run the tests in Ruby 2.2.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message