avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Willem van Bergen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AVRO-1559) Drop support for Ruby 1.8
Date Thu, 21 Jan 2016 13:39:40 GMT

    [ https://issues.apache.org/jira/browse/AVRO-1559?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15110588#comment-15110588
] 

Willem van Bergen commented on AVRO-1559:
-----------------------------------------

If we're going to drop support for Ruby versions anyway, we should drop support for 1.9 as
well because it is also EOL, and will no longer receive security fixes.

> Drop support for Ruby 1.8
> -------------------------
>
>                 Key: AVRO-1559
>                 URL: https://issues.apache.org/jira/browse/AVRO-1559
>             Project: Avro
>          Issue Type: Wish
>    Affects Versions: 1.7.7
>            Reporter: Willem van Bergen
>            Assignee: Willem van Bergen
>             Fix For: 1.8.0
>
>         Attachments: AVRO-1559.patch
>
>
> - Ruby 1.8 is EOL, and is even security issues aren't addressed anymore. 
> - It is also getting hard to set up Ruby 1.8 to run the tests (e.g. on a recent OSX,
it won't compile without manual fiddling).
> - Handling character encodings in Ruby 1.9 is very different than Ruby 1.8. Supporting
both at the same time adds a lot of overhead.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message