avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doug Cutting (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AVRO-1628) Add Schema.createUnion(Schema... type)
Date Mon, 12 Jan 2015 22:48:34 GMT

    [ https://issues.apache.org/jira/browse/AVRO-1628?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14274319#comment-14274319

Doug Cutting commented on AVRO-1628:

+1 This looks like a useful addition to me.

Only minor modification I'd suggest is to, in the test, put NULL first in the union, as is
best practice.

I'll commit this soon unless someone objects.

> Add Schema.createUnion(Schema... type)
> --------------------------------------
>                 Key: AVRO-1628
>                 URL: https://issues.apache.org/jira/browse/AVRO-1628
>             Project: Avro
>          Issue Type: Improvement
>          Components: java
>            Reporter: Clément MAHTIEU
>            Priority: Trivial
>         Attachments: AVRO-1628.patch
> Quite often, when I declare mapreduce jobs I have to create the union of two or three
schemas. For example:
> {code}
> AvroJob.setMapOutputKeySchema(job, Schema.createUnion(Arrays.asList(Foo.SCHEMA$, Bar.SCHEMA$))
> {code}
> Having Schema.createUnion only accept a List hurts readability and force users to write
boilerplate code for such trivial, but I believe common, use cases. It would be create to
add {{Schema.createUnion(Schema... type)}} 

This message was sent by Atlassian JIRA

View raw message