avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tom White (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AVRO-1573) lan/js: grunt : which version must be used ?
Date Thu, 11 Dec 2014 12:09:13 GMT

    [ https://issues.apache.org/jira/browse/AVRO-1573?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14242451#comment-14242451
] 

Tom White commented on AVRO-1573:
---------------------------------

It looks like Ubuntu 14.04 now uses [nodejs 0.10.25|http://packages.ubuntu.com/trusty/nodejs]
(not 0.8.x) and grunt 0.4.5. (I found this while working on AVRO-1537.) The build fails with

{noformat}
% ./build.sh test
./build.sh: line 25: node_modules/grunt/bin/grunt: No such file or directory
{noformat}

Grunt changed quite a bit between 0.3 and 0.4 according to this: http://gruntjs.com/upgrading-from-0.3-to-0.4.

We should probably just fix the test to run with grunt 0.4.

> lan/js: grunt : which version must be used ?
> --------------------------------------------
>
>                 Key: AVRO-1573
>                 URL: https://issues.apache.org/jira/browse/AVRO-1573
>             Project: Avro
>          Issue Type: Bug
>    Affects Versions: 1.7.4
>         Environment: Several (RHEL/x86_64 - Ubuntu/PPC64LE - RHEL/PPC64)
>            Reporter: Tony Reix
>
> We are trying to launch the tests of lang/js, on different environments. And we are facing
issues with grunt, on all these environments. It seems to us that Avro 1.74 does not work
with fresh versions of grunt. However, we cannot find which version of grunt is required by
Avro 1.7.4 .
> So, we have 2 questions:
>  - which version of grunt must be used for testing lang/js of Avro 1.7.4 ?
>  - do you have plans in Avro 1.7.8 for handling fresh versions of grunt ?
> Or maybe we are missing something...
> Thanks



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message