avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doug Cutting (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AVRO-1342) ObjectCreator fails if bad assemblies loaded
Date Tue, 05 Aug 2014 17:58:14 GMT

    [ https://issues.apache.org/jira/browse/AVRO-1342?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14086551#comment-14086551
] 

Doug Cutting commented on AVRO-1342:
------------------------------------

David, does Dmitry's patch fix things for you?

Also, is it possible to add a unit test for this?

> ObjectCreator fails if bad assemblies loaded
> --------------------------------------------
>
>                 Key: AVRO-1342
>                 URL: https://issues.apache.org/jira/browse/AVRO-1342
>             Project: Avro
>          Issue Type: Bug
>          Components: csharp
>    Affects Versions: 1.7.4
>         Environment: Windows, Visual Studio
>            Reporter: David Taylor
>             Fix For: 1.7.8
>
>         Attachments: AVRO-1342-csharp-ObjectCreator-fix.patch, continue-on-exception.diff
>
>
> When iterating over the list of assemblies in ObjectCreator.cs the GetTypes() call can
fail with an exception if there is a load error on an assembly.  Currently this exception
is propagated but really does not need to be.  I think a more reasonable approach is to note
the error and then try the next assembly. 



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message