avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitry Kovalev (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AVRO-843) Provide support for .NET 3.5
Date Wed, 06 Aug 2014 09:13:12 GMT

     [ https://issues.apache.org/jira/browse/AVRO-843?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dmitry Kovalev updated AVRO-843:
--------------------------------

    Attachment: AVRO-843-csharp-targetframework-fix.patch

As of version 1.7.6, all the code is already 3.5-compliant, and the mono build script appears
to set the target framework centrally to 3.5.

So the only thing left is to update Visual Studio project files to target 3.5 when the code
is built via Visual studio - attaching a small patch.

> Provide support for .NET 3.5
> ----------------------------
>
>                 Key: AVRO-843
>                 URL: https://issues.apache.org/jira/browse/AVRO-843
>             Project: Avro
>          Issue Type: Improvement
>          Components: csharp
>            Reporter: Dona Alvarez
>            Assignee: Dona Alvarez
>             Fix For: 1.7.8
>
>         Attachments: AVRO-843-csharp-targetframework-fix.patch, AVRO-843.patch
>
>
> Currently, minimum .NET version is 4.0 in Windows. We have clients on .NET 3.5 that would
like to use Avro. I will attach a patch soon.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message