avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christophe Taton (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AVRO-1382) Support for python3
Date Thu, 09 Jan 2014 01:02:09 GMT

     [ https://issues.apache.org/jira/browse/AVRO-1382?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Christophe Taton updated AVRO-1382:
-----------------------------------

    Attachment: AVRO-1382.20140108-165947-0800.diff

Here is a new patch that properly copies the resource files from the globally shared directory.
I believe this still requires python 3.3+ and pip 1.5.


> Support for python3
> -------------------
>
>                 Key: AVRO-1382
>                 URL: https://issues.apache.org/jira/browse/AVRO-1382
>             Project: Avro
>          Issue Type: Bug
>          Components: python
>    Affects Versions: 1.7.5
>            Reporter: Christophe Taton
>         Attachments: AVRO-1382.20131203-001922.diff, AVRO-1382.20140101-123233-0800.diff,
AVRO-1382.20140107-231626-0800.diff, AVRO-1382.20140108-165947-0800.diff
>
>
> Hi,
> I'd need to use Avro from Python3, which would require essentially the following changes,
which I am happy to contribute:
>  - rewrite except statements according to new syntax
>  - rewrite print statements according to new syntax
>  - basestring becomes str
>  - update some imports (StringIO becomes io.StringIO, httplib becomes http.client)
> This would apparently require branching the python code to maintain a version for python2
and a separate version for python3.
> Any thoughts on how to approach this?
> Thanks!



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message