avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doug Cutting (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AVRO-1126) Upgrade to Jackson 2+
Date Fri, 25 Oct 2013 22:42:30 GMT

    [ https://issues.apache.org/jira/browse/AVRO-1126?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13805774#comment-13805774
] 

Doug Cutting commented on AVRO-1126:
------------------------------------

Android's json libraries do not implement a standard, abstract API.

The javax.json glassfish implementation looks to be a considerably smaller than Jackson. 
So switching to using the javax.json API for parsing & printing JSON should permit one
to choose between Jackson and at least one smaller implementation, but not the implementation
built into Android.

Note that this is separate from the representation used for default values in Avro's public
API.  For that, I'm currently leaning towards something like Map<String,Object>, etc.

> Upgrade to Jackson 2+
> ---------------------
>
>                 Key: AVRO-1126
>                 URL: https://issues.apache.org/jira/browse/AVRO-1126
>             Project: Avro
>          Issue Type: Task
>          Components: java
>            Reporter: James Tyrrell
>            Priority: Critical
>             Fix For: 1.8.0
>
>
> Quite annoyingly with Jackson 2+ the base package name has changed from org.codehaus.jackson
to com.fasterxml.jackson so in addition to changing the dependencies from:
> {code:xml} 
> <dependency>
>     <groupId>org.codehaus.jackson</groupId>
>     <artifactId>jackson-core-asl</artifactId>
>     <version>${jackson.version}</version>
> </dependency>
> <dependency>
>     <groupId>org.codehaus.jackson</groupId>
>     <artifactId>jackson-mapper-asl</artifactId>
>     <version>${jackson.version}</version>
> </dependency>
> {code} 
> to:
> {code:xml} 
> <dependency>
>     <groupId>com.fasterxml.jackson.core</groupId>
>     <artifactId>jackson-core</artifactId>
>     <version>${jackson.version}</version>
> </dependency>
> <dependency>
>     <groupId>com.fasterxml.jackson.core</groupId>
>     <artifactId>jackson-databind</artifactId>
>     <version>${jackson.version}</version>
> </dependency>
> {code} 
> the base package in the code needs to be updated. More info can be found [here|http://wiki.fasterxml.com/JacksonUpgradeFrom19To20],
I am happy to do the work just let me know what is preferable i.e. should I just attach a
patch to this issue?



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message