avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject Build failed in Jenkins: AVRO-python #297
Date Mon, 21 May 2012 13:21:15 GMT
See <https://builds.apache.org/job/AVRO-python/297/changes>

Changes:

[dcreager] AVRO-1087. C: avro_file_writer_open() and appending values works correctly.

The avro_file_writer_open() function wasn't correctly setting up the
avro_file_writer_t instance to allow you to append data to an existing
file.  We now open up the file for read+write, read in the header, and
set up the writer's codec to match what's in the existing file.  The
patch includes a test case.

Contributed by Pugachev Maxim.

------------------------------------------
Started by an SCM change
Building remotely on ubuntu4 in workspace <https://builds.apache.org/job/AVRO-python/ws/>
Reverting <https://builds.apache.org/job/AVRO-python/ws/trunk>
Updating https://svn.apache.org/repos/asf/avro/trunk
U         lang/c/src/datafile.c
A         lang/c/tests/test_avro_1087.c
U         lang/c/tests/CMakeLists.txt
U         CHANGES.txt
At revision 1341006
[py] $ /home/hudson/tools/ant/latest/bin/ant -file build.xml test
Buildfile: <https://builds.apache.org/job/AVRO-python/ws/trunk/lang/py/build.xml>

init:

build:
     [copy] Copying 1 file to <https://builds.apache.org/job/AVRO-python/ws/trunk/lang/py/build/src/avro>
     [copy] Copying 1 file to <https://builds.apache.org/job/AVRO-python/ws/trunk/lang/py/build>
     [copy] Copying 1 file to <https://builds.apache.org/job/AVRO-python/ws/trunk/lang/py/build/scripts>
     [copy] Copying 1 file to <https://builds.apache.org/job/AVRO-python/ws/trunk/lang/py/build/test>

test:
test_datafile.py
test_io.py
test_ipc.py
test_protocol.py
test_schema.py
test_script.py
Modules: 'test_datafile','test_datafile','test_io','test_ipc','test_protocol','test_schema','test_script'
Non-null modules arg. creating script
pythonpath: <https://builds.apache.org/job/AVRO-python/ws/trunk/lang/py/build/src>:<https://builds.apache.org/job/AVRO-python/ws/trunk/lang/py/build/test>:<https://builds.apache.org/job/AVRO-python/ws/trunk/lang/py/build/lib>
  [py-test] Traceback (most recent call last):
  [py-test]   File "<stdin>", line 2, in <module>
  [py-test]   File "/usr/lib/python2.6/unittest.py", line 816, in __init__
  [py-test]     self.parseArgs(argv)
  [py-test]   File "/usr/lib/python2.6/unittest.py", line 843, in parseArgs
  [py-test]     self.createTests()
  [py-test]   File "/usr/lib/python2.6/unittest.py", line 849, in createTests
  [py-test]     self.module)
  [py-test]   File "/usr/lib/python2.6/unittest.py", line 613, in loadTestsFromNames
  [py-test]     suites = [self.loadTestsFromName(name, module) for name in names]
  [py-test]   File "/usr/lib/python2.6/unittest.py", line 576, in loadTestsFromName
  [py-test]     module = __import__('.'.join(parts_copy))
  [py-test]   File "<https://builds.apache.org/job/AVRO-python/ws/trunk/lang/py/build/test/test_ipc.py",>
line 26, in <module>
  [py-test]     from avro import ipc, txipc
  [py-test]   File "<https://builds.apache.org/job/AVRO-python/ws/trunk/lang/py/build/src/avro/ipc.py",>
line 20, in <module>
  [py-test]     from urllib3.connectionpool import HTTPConnectionPool
  [py-test] ImportError: No module named urllib3.connectionpool

BUILD FAILED
<https://builds.apache.org/job/AVRO-python/ws/trunk/lang/py/build.xml>:130: Test execution
failed.  See output for details.

Total time: 1 second
Build step 'Invoke Ant' marked build as failure

Mime
View raw message