avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thiruvalluvan M. G. (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AVRO-1068) Avro Java does not build on recent Eclipse versions with m2eclipse
Date Fri, 20 Apr 2012 06:07:37 GMT

     [ https://issues.apache.org/jira/browse/AVRO-1068?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Thiruvalluvan M. G. updated AVRO-1068:
--------------------------------------

    Attachment: AVRO-1068.patch

This patch ensures that the current versions of Eclipse do not complain. Since the changes
are in {{plugnManagement}} section of {{pom.xml}} there is has no impact if Eclipse is not
used or when older versions of Eclipse/m2eclipse are used.
                
> Avro Java does not build on recent Eclipse versions with m2eclipse
> ------------------------------------------------------------------
>
>                 Key: AVRO-1068
>                 URL: https://issues.apache.org/jira/browse/AVRO-1068
>             Project: Avro
>          Issue Type: Improvement
>          Components: java
>    Affects Versions: 1.7.0
>            Reporter: Thiruvalluvan M. G.
>            Assignee: Thiruvalluvan M. G.
>             Fix For: 1.7.0
>
>         Attachments: AVRO-1068.patch
>
>
> It is so because, in the recent versions of m2eclipse require manual mapping of non-standard
maven lifecycle tasks. The forthcoming fix addresses that problem.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message