avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Douglas Creager (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AVRO-1004) avropipe displays NUL terminator for string values
Date Tue, 24 Jan 2012 16:16:42 GMT

     [ https://issues.apache.org/jira/browse/AVRO-1004?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Douglas Creager updated AVRO-1004:
----------------------------------

    Attachment: 0001-AVRO-1004.-C-avropipe-Don-t-display-NUL-terminators-.patch

Here's a patch.
                
> avropipe displays NUL terminator for string values
> --------------------------------------------------
>
>                 Key: AVRO-1004
>                 URL: https://issues.apache.org/jira/browse/AVRO-1004
>             Project: Avro
>          Issue Type: Bug
>          Components: c
>    Affects Versions: 1.6.1
>            Reporter: Douglas Creager
>            Assignee: Douglas Creager
>         Attachments: 0001-AVRO-1004.-C-avropipe-Don-t-display-NUL-terminators-.patch
>
>
> The avropipe tool displays the NUL terminator for any string values:
> {noformat}
> $ avropipe examples/quickstop.db | head -n 7
> /	[]
> /0	{}
> /0/ID	1
> /0/First	"Dante\u0000"
> /0/Last	"Hicks\u0000"
> /0/Phone	"(0)\u0000"
> /0/Age	32
> {noformat}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message