avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeremy Lewi (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AVRO-878) TestWordCount.testProjection is broken
Date Sat, 03 Sep 2011 15:52:09 GMT

     [ https://issues.apache.org/jira/browse/AVRO-878?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jeremy Lewi updated AVRO-878:
-----------------------------

    Attachment: TEST-org.apache.avro.mapred.TestWordCount.xml

Here's the surefire output for TestWordCount.

Perhaps, I'm misusing maven and therefore pulling in the wrong dependencies so here's what
I did.

1. cd AVRO/lang/java
2. mvn install -D skipTests
3. cd mapred
4  mvn test -X

I ran "mvn test" from the mapred subdirectory because if I tried to run from the "java" directory,
I got test failures in the "ipc" package and this caused the tests for subsequent packages
to be skipped.

> TestWordCount.testProjection is broken
> --------------------------------------
>
>                 Key: AVRO-878
>                 URL: https://issues.apache.org/jira/browse/AVRO-878
>             Project: Avro
>          Issue Type: Test
>    Affects Versions: 1.6.0
>            Reporter: Jeremy Lewi
>            Assignee: Jeremy Lewi
>             Fix For: 1.6.0
>
>         Attachments: AVRO-878.patch, TEST-org.apache.avro.mapred.TestWordCount.xml, TEST-org.apache.avro.mapred.TestWordCount.xml
>
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> TestWordCount.testProjection in avro/mapred/TestWordCount.java  is broken. It appears
to be using the wrong schema to read the output of the map reduce job.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message