avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Miki Tebeka (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AVRO-833) Don't require simplejson when not needed
Date Tue, 31 May 2011 17:22:47 GMT

     [ https://issues.apache.org/jira/browse/AVRO-833?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Miki Tebeka updated AVRO-833:
-----------------------------

    Attachment:     (was: setup.patch)

> Don't require simplejson when not needed
> ----------------------------------------
>
>                 Key: AVRO-833
>                 URL: https://issues.apache.org/jira/browse/AVRO-833
>             Project: Avro
>          Issue Type: Bug
>          Components: python
>            Reporter: Miki Tebeka
>            Priority: Minor
>              Labels: python
>         Attachments: setup.patch
>
>
> Currently setup.py required simplejson unconditionally. However since json was added
to python 2.6 and up (and the avro code tries to use the build in module first), require it
only if python version is 2.5 or lower.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message