avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doug Cutting (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AVRO-787) Ruby 1.9 compatibility to 'require' and run tests
Date Fri, 25 Mar 2011 18:04:05 GMT

     [ https://issues.apache.org/jira/browse/AVRO-787?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Doug Cutting updated AVRO-787:
------------------------------

    Fix Version/s: 1.5.1
         Assignee: Michael L. Artz

This passes tests for me using Ruby 1.8, so it appears to be a back-compatible change.

Unless there are objections, I'll commit this soon for inclusion in 1.5.1.

> Ruby 1.9 compatibility to 'require' and run tests
> -------------------------------------------------
>
>                 Key: AVRO-787
>                 URL: https://issues.apache.org/jira/browse/AVRO-787
>             Project: Avro
>          Issue Type: Improvement
>          Components: ruby
>    Affects Versions: 1.6.0
>         Environment: Mac OSX, Rubies installed with RVM
>            Reporter: Michael L. Artz
>            Assignee: Michael L. Artz
>              Labels: ruby
>             Fix For: 1.5.1
>
>         Attachments: 0001-Basic-Ruby-1.9-updates.patch
>
>
> The avro gem does not 'require' on Ruby 1.9, complaining about a missing 'md5'.  It also
uses a bunch of Ruby 1.8 string-isms, like assuming that Strings enumerate to bytes, which
is not necessarily true in 1.9.  

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message