avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John McHugh (JIRA)" <j...@apache.org>
Subject [jira] Created: (AVRO-736) test_valgrind fails during make check for avro-c-1.4.1
Date Tue, 18 Jan 2011 19:10:45 GMT
test_valgrind fails during make check for avro-c-1.4.1
------------------------------------------------------

                 Key: AVRO-736
                 URL: https://issues.apache.org/jira/browse/AVRO-736
             Project: Avro
          Issue Type: Bug
          Components: c
    Affects Versions: 1.4.1
         Environment: Macbook Pro 2.53Ghz Intel Core I5, 8GB Ram, OSX 10.6.4
            Reporter: John McHugh


Downloaded c-1.4.1 fron stable.  First "./configure; make; make check" failed because valgrind
not found.  Did "sudo port valgrind  @3.6.0" to install.  Did " make check" then "make distclean;
./configure; make; make check" and got the following both times.

PASS: test_avro_data
PASS: test_cpp
+ which valgrind
/opt/local/bin/valgrind
+ LD_LIBRARY_PATH=../src/.libs/
+ valgrind --leak-check=full --show-reachable=yes -q .libs/test_avro_data
+ grep -E '^==[0-9]+== '
==29176== 
==29176== Process terminating with default action of signal 5 (SIGTRAP)
==29176==    at 0x7FFF5FC01065: dyld_fatal_error (in /usr/lib/dyld)
==29176==    by 0x7FFF5FC0699B: dyld::_main(macho_header const*, unsigned long, int, char
const**, char const**, char const**) (in /usr/lib/dyld)
==29176==    by 0x7FFF5FC016D1: dyldbootstrap::start(macho_header const*, int, char const**,
long) (in /usr/lib/dyld)
==29176==    by 0x7FFF5FC01051: _dyld_start (in /usr/lib/dyld)
==29176==    by 0xFFFFFFFF: ???
+ '[' 0 -eq 0 ']'
+ exit 1
FAIL: test_valgrind
==========================================================
1 of 4 tests failed
Please report to http://issues.apache.org/jira/browse/AVRO
==========================================================
Make[2]: *** [check-TESTS] Error 1
make[1]: *** [check-am] Error 2
make: *** [check-recursive] Error 1
bash-3.2$ 

This is my first attempt at building any avro component, so it is entirely possible that I
have done something wrong to cause this.


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message