avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Gargan (JIRA)" <j...@apache.org>
Subject [jira] Updated: (AVRO-693) Missing velocity logging configuration causes error in clean build
Date Thu, 04 Nov 2010 22:44:48 GMT

     [ https://issues.apache.org/jira/browse/AVRO-693?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Stephen Gargan updated AVRO-693:
--------------------------------

    Attachment: logchute.patch

> Missing velocity logging configuration causes error in clean build 
> -------------------------------------------------------------------
>
>                 Key: AVRO-693
>                 URL: https://issues.apache.org/jira/browse/AVRO-693
>             Project: Avro
>          Issue Type: Bug
>          Components: java
>         Environment: Linux 2.6.32-25-generic 
>            Reporter: Stephen Gargan
>            Priority: Minor
>             Fix For: 1.5.0
>
>         Attachments: logchute.patch
>
>
> I'm seeing an issue with a clean build (ant clean dist) where the Initialization of the
VelocityEngine in the SpecificCompiler fails. Its trying to obtain a Servlet context for the
default ServletLogChute. Configuring the engine to use the NullLogChute fixes the issue.
>     velocityEngine.setProperty("runtime.log.logsystem.class", 
>     	"org.apache.velocity.runtime.log.NullLogChute");

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message