avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thiruvalluvan M. G. (JIRA)" <j...@apache.org>
Subject [jira] Updated: (AVRO-664) Ruby server takes a long time to start in interop tests
Date Fri, 10 Sep 2010 08:26:32 GMT

     [ https://issues.apache.org/jira/browse/AVRO-664?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Thiruvalluvan M. G. updated AVRO-664:
-------------------------------------

    Attachment: AVRO-664.patch

The patch addresses both the problems.

It fixes the name in tools.rb and makes the shell script wait for variable amount of time
(up to 60 seconds). Either of the fixes is actually sufficient. But I thought an extra level
of protection will not hurt.

> Ruby server takes a long time to start in interop tests
> -------------------------------------------------------
>
>                 Key: AVRO-664
>                 URL: https://issues.apache.org/jira/browse/AVRO-664
>             Project: Avro
>          Issue Type: Bug
>          Components: ruby
>    Affects Versions: 1.4.0
>         Environment: Ubuntu Lucid Lynx
>            Reporter: Thiruvalluvan M. G.
>            Assignee: Thiruvalluvan M. G.
>             Fix For: 1.4.1
>
>         Attachments: AVRO-664.patch
>
>
> The ruby server uses a wrong key in the config (:Host instead of :BindAddress) which
cause Socket::getaddrinfo() take up to 15 seconds. The shell script which starts the server
waits for jist 1 second and test fails abruptly.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message