avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gavin M. Roy (JIRA)" <j...@apache.org>
Subject [jira] Created: (AVRO-629) avro_array_get is a misnomer
Date Wed, 25 Aug 2010 22:32:18 GMT
avro_array_get is a misnomer
----------------------------

                 Key: AVRO-629
                 URL: https://issues.apache.org/jira/browse/AVRO-629
             Project: Avro
          Issue Type: Improvement
          Components: c
    Affects Versions: 1.4.0
            Reporter: Gavin M. Roy


The new function avro_array_get is a misnomer since it only allows you to grab a single datum
from the array passing in the index of the datum.  It should renamed to reflect this behavior.
 A suggestion would be to rename it to avro_array_get_datum_at_index().

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message