avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doug Cutting (JIRA)" <j...@apache.org>
Subject [jira] Updated: (AVRO-597) Avro should be usable from JDK 1.5 programs
Date Tue, 24 Aug 2010 21:10:17 GMT

     [ https://issues.apache.org/jira/browse/AVRO-597?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Doug Cutting updated AVRO-597:
------------------------------

           Status: Open  (was: Patch Available)
    Fix Version/s:     (was: 1.4.0)

> Do we want to set the requirement to "Avro requires JDK 1.5 or later to build" or "Avro
requires JRE 1.5 or later to run"? 

I agree that running in Java 1.5 should be sufficient.

> Avro should be usable from JDK 1.5 programs
> -------------------------------------------
>
>                 Key: AVRO-597
>                 URL: https://issues.apache.org/jira/browse/AVRO-597
>             Project: Avro
>          Issue Type: Improvement
>          Components: build, java
>    Affects Versions: 1.3.3
>            Reporter: Jon Travis
>         Attachments: avro-597-jdk15.patch
>
>
> Our application needs to run on a 1.5 JDK, but Avro classes are built for 1.6. 
> The change to get this to work are pretty minimal.  
>   - Removed @Override on interfaces, since 1.5 does not support this
>   - Replace usage of Arrays.copyOf with our own version of it

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message