avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Philip Zeyliger (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AVRO-618) Avro doesn't work with python 2.4
Date Thu, 19 Aug 2010 23:51:18 GMT

    [ https://issues.apache.org/jira/browse/AVRO-618?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12900531#action_12900531
] 

Philip Zeyliger commented on AVRO-618:
--------------------------------------

They're pretty close.  I actually got rid of uuid completely, and just used the same mechanism
that it uses to get a random 16 bytes, since there's no need to create the UUID object if
all we're looking for is 16  random bytes.

I think the code has moved a bit, so mine might apply more cleanly.  Haven't tried applying
588.

I've also updated the build.xml file to run arbitrary versions of python easily, so this is
easier to reproduce.

> Avro doesn't work with python 2.4
> ---------------------------------
>
>                 Key: AVRO-618
>                 URL: https://issues.apache.org/jira/browse/AVRO-618
>             Project: Avro
>          Issue Type: Bug
>    Affects Versions: 1.4.0
>            Reporter: Philip Zeyliger
>         Attachments: AVRO-618.patch.txt
>
>
> The avro tests fail on a system with python2.4.  The issues can be easily worked around
by avoiding python2.5 constructs and libraries.
> The missing "struct.Struct" is what started me down this path, but I also ended up tackling
a few other similar issues and re-jiggering slightly the build.xml to allow for "ant test
-Dpython=python2.4" to work.
> {noformat}
>   File "build/bdist.macosx-10.5-i386/egg/avro/io.py", line 52, in ?
> AttributeError: 'module' object has no attribute 'Struct'
> {noformat}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message