avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scott Carey (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AVRO-582) java: add comment to generated code warning not to call set & get
Date Fri, 18 Jun 2010 01:18:23 GMT

    [ https://issues.apache.org/jira/browse/AVRO-582?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12880029#action_12880029

Scott Carey commented on AVRO-582:

bq. do we have flexibility to rename them? Java APIs are riddled with gets and sets, whereas
this is more like readInternal, writeInternal or something.

Good idea.  Later we likely want to 'bean-ify' these with getters and setters, and these keywords
should be reserved for that purpose.  Unfortunately that is part of the IndexedRecord interface,
so has a somewhat broader impact.  internalGet and internalSet might also be reasonable names
for this.

> java: add comment to generated code warning not to call set & get
> -----------------------------------------------------------------
>                 Key: AVRO-582
>                 URL: https://issues.apache.org/jira/browse/AVRO-582
>             Project: Avro
>          Issue Type: Improvement
>          Components: java
>            Reporter: Doug Cutting
>            Assignee: Doug Cutting
>             Fix For: 1.4.0
> Java's specific compiler generates classes with set(int, Object) and get(int) methods,
used by the DatumReader and DatumWriter implementations to read and write instances.  These
methods are not intended for users to call, but must be public.  We should add a comment to
the generated code indicating this, to reduce confusion.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message