avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Hammerbacher (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AVRO-415) Allow Ruby implementation to work with older versions of Ruby
Date Tue, 16 Feb 2010 20:49:28 GMT

    [ https://issues.apache.org/jira/browse/AVRO-415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12834459#action_12834459
] 

Jeff Hammerbacher commented on AVRO-415:
----------------------------------------

Huzzah, "rake test" passes! Thanks, Jeff. +1

> Allow Ruby implementation to work with older versions of Ruby
> -------------------------------------------------------------
>
>                 Key: AVRO-415
>                 URL: https://issues.apache.org/jira/browse/AVRO-415
>             Project: Avro
>          Issue Type: Improvement
>          Components: ruby
>            Reporter: Jeff Hammerbacher
>            Assignee: Jeff Hodges
>         Attachments: 187onanundercoverproc.patch, AVRO-415.patch
>
>
> On Mac OS X Leopard with Ruby 1.8.6, running "rake test" results in:
> {quote}
> $ rake test
> (in /Users/hammer/codebox/avro-trunk/lang/ruby)
> /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby -Ilib:ext:bin:test
"/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake/rake_test_loader.rb"
"test/test_help.rb" "test/test_io.rb" "test/test_protocol.rb"
> ./lib/avro/schema.rb:290:in `initialize': wrong argument type Symbol (expected Proc)
(TypeError)
>     from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `each_with_index'
>     from ./lib/avro/schema.rb:274:in `each'
>     from ./lib/avro/schema.rb:274:in `each_with_index'
>     from ./lib/avro/schema.rb:274:in `initialize'
>     from ./lib/avro/schema.rb:72:in `new'
>     from ./lib/avro/schema.rb:72:in `real_parse'
>     from ./lib/avro/schema.rb:372:in `initialize'
>     from ./lib/avro/schema.rb:170:in `new'
>      ... 16 levels...
>     from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake/rake_test_loader.rb:5:in
`load'
>     from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake/rake_test_loader.rb:5
>     from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake/rake_test_loader.rb:5:in
`each'
>     from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake/rake_test_loader.rb:5
> rake aborted!
> Command failed with status (1): [/System/Library/Frameworks/Ruby.framework/...]
> (See full trace by running task with --trace)
> {quote}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message