avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thiruvalluvan M. G. (JIRA)" <j...@apache.org>
Subject [jira] Created: (AVRO-281) Symlink in build.xml does not work well with Cygwin
Date Mon, 04 Jan 2010 00:42:54 GMT
Symlink in build.xml does not work well with Cygwin
---------------------------------------------------

                 Key: AVRO-281
                 URL: https://issues.apache.org/jira/browse/AVRO-281
             Project: Avro
          Issue Type: Bug
          Components: java
            Reporter: Thiruvalluvan M. G.
            Assignee: Thiruvalluvan M. G.
         Attachments: AVRO-281.patch

Ant's symlink task seems to have trouble if the link already exists. So any attempt to build
for a second time fails. We use symlink to link version specific JavaCC jar to javacc.jar.
Curiously, even if you succeed in symlink for javacc, javacc task fails with an error that
javacc.jar or JavaCC.zip cannot be found in path. It appears that the ant problem has been
around for some time: http://www.mail-archive.com/nutch-dev@incubator.apache.org/msg00880.html.

The forthcoming patch addresses the problem by replacing symlink with a delete and copy. I
could have simply used copy with overwrite="true", but, I'm not sure how it'll behave with
existing symlinks.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message