avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doug Cutting (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AVRO-372) Rename genavro to something like AvroIDL
Date Sat, 23 Jan 2010 00:39:21 GMT

    [ https://issues.apache.org/jira/browse/AVRO-372?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12803966#action_12803966
] 

Doug Cutting commented on AVRO-372:
-----------------------------------

The Avro schema language is JSON, so I don't like that.  AvroHL (high level)? Avro++?

> Rename genavro to something like AvroIDL
> ----------------------------------------
>
>                 Key: AVRO-372
>                 URL: https://issues.apache.org/jira/browse/AVRO-372
>             Project: Avro
>          Issue Type: Task
>            Reporter: Todd Lipcon
>
> No one likes the name genavro. Let's rename to one of these:
> - AvroIDL (Interface Description Language)
> - AvroHDL (Highlevel Description Language)
> - AvroDL (Description Language)
> The abbreviation IDL might conjure up CORBA nightmares for people. Thoughts?

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message