avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scott Carey <sc...@richrelevance.com>
Subject Re: Reserving more keywords in Avro Object Container Files?
Date Fri, 22 Jan 2010 19:18:55 GMT
It makes sense to just reserve avro.*.  There is no need for this namespace to exactly line
up with the java code namespace, and like that it is succinct.

On the specific needs for compression options, I would rather have avro.codec.options as a
general purpose container for codec options than
avro.codec.compression_level.   Some codecs have compression levels like gzip, 0 to 9.  Others
have a set of flags or multiple dimensions of options.  Each codec can do what it will with
avro.codec.options.   Deflate can have "level=[0-9]" for values.
Additionally, the Codec API can incorporate a 

public String getOptions();
public void SetOptions(String options); 

interface so that file appends can pick up the options that the file was created with.


On Jan 22, 2010, at 10:33 AM, Philip Zeyliger wrote:

> I'm +1 avro.*, and I'm also +1 doing this before 1.3.  It sounds like
> we're approaching consensus.
> I've filed https://issues.apache.org/jira/browse/AVRO-368.  If you
> wish to pipe up, now's your chance!
> -- Philip

View raw message