avro-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scott Banachowski (JIRA)" <j...@apache.org>
Subject [jira] Updated: (AVRO-71) Followup - making some C++ object APIs more generic
Date Fri, 03 Jul 2009 18:37:47 GMT

     [ https://issues.apache.org/jira/browse/AVRO-71?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Scott Banachowski updated AVRO-71:

    Attachment: AVRO-71.patch

This is the svn diff for the patch.

Last time I renamed files in a patch, in the repository it left 0 size files instead of removing
This patch has also renamed files, so after applying the patch, if any 0 size files remain
instead of getting deleted, please remove them.

> Followup - making some C++ object APIs more generic
> ---------------------------------------------------
>                 Key: AVRO-71
>                 URL: https://issues.apache.org/jira/browse/AVRO-71
>             Project: Avro
>          Issue Type: Improvement
>          Components: c++
>            Reporter: Scott Banachowski
>            Assignee: Scott Banachowski
>             Fix For: 1.0.0
>         Attachments: AVRO-71.patch
> This is a followup to issue AVRO-59.  In that change, a more generic version of Writer
class was created to support templates.
> I now have done the same kind of refactor for the Reader version, to make Reader and
Writer more symmetric.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message