avalon-phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Johan Sjöberg <johan.sjob...@avaintec.com>
Subject Phoenix work directory
Date Tue, 24 Sep 2002 13:53:28 GMT
Hi!

Andrei Ivanov reported a problem with deleting the temporary directories 
inside Phoenix's work directory on Windows some months ago.

http://www.mail-archive.com/avalon-phoenix-dev@jakarta.apache.org/msg00607.html

I had the same problem then (WinXP), but I thought it got fixed and 
forgot about the whole issue. Today I tested my projects on Phoenix 4.0, 
release version, and I still have this problem.

To test if this was a problem with my applications only, I compiled the 
demo from avalon-apps and it produces the same result. I can't find any 
problems with file level security or java's security manager (no 
difference if I turn it off).

I'm sorry if I am bringing up something that has already been solved. I 
have the feeling that I'm missing something really simple here.


Peter,
in your proposal for the work directory (in Bugzilla) you mentioned that 
it should be removed on startup as it still includes the temporary 
directories if Phoenix was uncleanly shutdown. Will this be added at 
some point, or is this the whole issue that Phoenix is killed with 
Ctrl-C? I get the same results with the Wrapper though...

                            ---o0o---

When checking the -Djava.security.manager parameter in /bin/run.bat I 
noticed that the parameter PHOENIX_SECURE is passed to the JVM. Isn't 
this a bug? It should be PHOENIX_SM if I'm not completely mistaken?? 
Patch included if needed...

//
Johan

Mime
View raw message