avalon-phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Hammant <Paul_Hamm...@yahoo.com>
Subject Re: Stable branch
Date Wed, 11 Sep 2002 22:55:28 GMT
Johan

>>> Also, trying to cause the shutdown of the working wrapper with ' wrapper
>>> -c ..\conf\wrapper.conf wrapper.java.command=shutdown' proves less that
>>> fruitfull as the wrapper claims :
>>>
>>>  C:\ApacheUPD\jakarta-avalon-phoenix-402\dist\bin>
>>>  C:\ApacheUPD\jakarta-avalon-phoenix-402\dist\bin>wrapper -c ..\con
>>>  wrapper  | --> Wrapper Started as Console
>>>  wrapperp | port 15012 already in use, using port 15013 instead.
>>>  wrapper  | Launching a JVM...
>>>  wrapper  | can not execute ""shutdown" -Djava.ext.dirs=../lib -Dph
>>>  META-INF/java.policy -Djava.security.manager -Xms16m -Xmx64m -Djav
>>>  wrapper.key="iUV6mSMAxfVobB87" -Dwrapper.port=15013 -Dwrapper.jvmi
>>>  wrapper  | Critical error: wait for JVM process failed
>>>
>>> I think we have some polishing to do.
>>
>
> Paul, I didn't know about this feature and I think you used it 
> incorrectly. On production systems the wrapper is probaly always run 
> as a service. If I test an application in the console I just shut it 
> down by pressing Ctrl-C.

I guess.  If you just invoke wrapper it offers these suggestions :

  Usage:
    wrapper <command> <config file> [config properties] [...]
  where <command> canbe one of:
    -c   run as a console application
    -i   install as an NT service
    -r   remove as an NT service
    -?   print this help message
  <config file> is the wrapper.conf to use
  [config properties] are configuration name-value pairs which override 
values
    in wrapper.conf.  For example:
    wrapper.debug=true

It was the -c option I was using.

> It gets funnier still ...
>
> The "wrapper.java.command=shutdown" command probably didn't work for 
> you as you don't have a shutdown.exe excecutable in you system, lucky 
> you... I run XP that has a C:\WINDOWS\system32\shutdown.exe and yes it 
> got triggered... MAN!!! It must be my lucky day though that 
> shutdown.exe doesn't work without some arguments. My hart stood still 
> for some seconds though as I had quite a few unsaved files. ;) ;)

Nahh, the shutdown thing works as I tried to use it except for a single 
fact - the wrapper exe could not bind to the port in use :

    "port 15012 already in use, using port 15013 instead. "

> Install it as a service and stop it with net stop phoenix as Peter sed.


Agree that this will work.  We shoudl try to prioduce documentation for 
-c as well though.

- Paul


--
To unsubscribe, e-mail:   <mailto:avalon-phoenix-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:avalon-phoenix-dev-help@jakarta.apache.org>


Mime
View raw message