avalon-phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicola Ken Barozzi <nicola...@apache.org>
Subject Re: MBean suffixed classes
Date Tue, 13 Aug 2002 15:02:09 GMT
Peter Donald wrote:
> On Tue, 13 Aug 2002 15:35, Paul Hammant wrote:
> 
>>Huw, Peter, Folks,
>>
>>I have to say I dislike the MBean suffix for JMX enabled beans.  In fact
>>it is my principle objection to JMX (yes I know it is anal).
> 
> 
> JMX does not require it - its just convention. What do you object to exactly - 
> a separate interface or just the suffix. You can quite easily name the 
> interface anything you want and phoenix will handle it gracefully. 
> 
> If it is the interface itselfyou don't like then it would seem I am the only 
> one that likes em ;)

;-)

>>Would it be possible to generate them?
> 
> yep. I believe many projects do.

Yes, they do, but please don't.
I strongly think that the code should never use a preprocessor, except 
when it's part of the language semantics (template-based programming).

It's useless, anal and confusing.

Overall, I usually use very descriptive names for my stuff; it makes 
them usually quite long, but I understand them better, ie if I have a 
String that holds an URL, I call it something like 
userDefinedTargetURLString. The last part is always about the behaviour 
of the object.

So MBean for Mbeans is not so bad after all IMHO.

-- 
Nicola Ken Barozzi                   nicolaken@apache.org
             - verba volant, scripta manent -
    (discussions get forgotten, just code remains)
---------------------------------------------------------------------


--
To unsubscribe, e-mail:   <mailto:avalon-phoenix-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:avalon-phoenix-dev-help@jakarta.apache.org>


Mime
View raw message