avalon-phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexis Agahi <a...@users.sourceforge.net>
Subject Re: Problems testing Phoenix prior to beta.
Date Sat, 10 Aug 2002 11:35:01 GMT
Paul Hammant wrote:
> Alexis, Huw,
> 
>>> Thanks for providing the earlier information.  I downloaded the 
>>> binary release from 8-7 and, sure enough, all the mbeans under the 
>>> phoenix domain were missing.  I was able to determine that the 
>>> problem has something to do with the conf/kernel.xml element:
>>>
>>> <stylesheets-dir>conf/xsl</stylesheets-dir>
>>
>>
> A complete guess, but it could have something to do with 
> Class.forName(..) use in mx4j.adaptor.http.HttpAdaptor
> 
>    public void addCommandProcessor(String path, String processorClass)
>    {
>        try {
>            HttpCommandProcessor processor = 
> (HttpCommandProcessor)Class.forName(processorClass).newInstance();
>            addCommandProcessor(path, processor);
>        } catch (Exception e) {
>            log.error("Exception creating Command Processor of class " + 
> processorClass, e);
>        }
>    }



Sorry Paul, maybe I missed something, but I cannot see any 
forName in src of the latest stable release: mx4j-1.1.tar.gz
http://prdownloads.sourceforge.net/mx4j/mx4j-1.1.tar.gz?download

I presume you are talking about the latest cvs snapshot.
http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/mx4j/mx4j/src/core/mx4j/adaptor/http/HttpAdaptor.java?rev=1.6&content-type=text/vnd.viewcvs-markup
Am I supposed to use this one for testing?



--
To unsubscribe, e-mail:   <mailto:avalon-phoenix-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:avalon-phoenix-dev-help@jakarta.apache.org>


Mime
View raw message