avalon-phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <pe...@apache.org>
Subject Re: Has assembly.xml format changed?
Date Wed, 22 May 2002 10:15:36 GMT
On Tue, 21 May 2002 23:34, Ulrich Mayring wrote:
> Peter Donald wrote:
> > Make sure that you update to the latest phoenix. It looks like you
> > updated to latest cornerstone but still running on an old phoenix.
>
> Nope, my Phoenix was only 1 or 2 days old, but I updated from cvs right
> now again, but the message is still the same. Some additional
> deprecation warnings appear (The Block named "dms" (implementation class
> "de.denic.app.dms.DMSSocketImpl"), implements Block interface. The Block
> interface has been deprecated and should no longer be used.), showing
> that the update was indeed performed. But I still get this:
>
> jvm 1    | java.lang.NullPointerException
> jvm 1    |      at
> org.apache.excalibur.threadcontext.ThreadContext.setThreadContext(ThreadCon
>text.java:95)

Hmm. I still think that you have some old jars somewhere in your installation. 
(Make sure there is only 1 excalibur-threadcontext jar in $PHOENIX_HOME/lib). 
The main reason being that ThreadContext.java:95 does not refer to a valid 
line on my copy of the source.

If I do a clean download from CVS and run the following

$ ant install -Dphoenix.home=install
$ cp avalon-demo.sar install/apps/
$  install/bin/run.sh

It all works fine for me. Not sure.


-- 
Cheers,

Peter Donald


--
To unsubscribe, e-mail:   <mailto:avalon-phoenix-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:avalon-phoenix-dev-help@jakarta.apache.org>


Mime
View raw message