avalon-phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrei Ivanov" <my...@surfeu.fi>
Subject Re: permissions question (environment.xml)
Date Fri, 17 May 2002 06:51:30 GMT
Hi, sorry for puzzling and putting different questions to one mail.
My question about bugzilla:

>Yesterday I tried to get bugzilla account but response with password never
>came...

(in Subject: Re: question about org.apache.avalon.cornerstone.blocks.sockets
package)
was in responce to this mail:

----- Original Message -----
From: "Peter Donald" <peter@apache.org>
To: "Avalon-Phoenix Developers List" <avalon-phoenix-dev@jakarta.apache.org>
Sent: Thursday, May 16, 2002 9:02 AM
Subject: Re: permissions question (environment.xml)


On Wed, 15 May 2002 22:28, Andrei Ivanov wrote:
> Hi,
> Two questions about permissions settings in environment.xml for a phoenix
> application:
> A. There are two types of permissions setings can be found in examples:
> 1.
>       <grant code-base="file:${app.home}${/}SAR-INF${/}*">
>         <permission class="java.security.AllPermission"/>
>       </grant>
>
> 2
>      <grant code-base="sar:SAR-INF/*">
>         <permission class="java.security.AllPermission" />
>      </grant>
>
> which one is correct?

The second one is better except the URL is of the form "sar:/SAR-INF/*"
(note
extra slash after "sar:"

> 2. If I have to let my application read files in any directory under
> "app.home" (not inside SAR-INF but one level up) what is the correct way
to
> set this permission. I've tried to set it the following way (found in
> reference-environment-specification.xml):
>
>      <grant code-base="file:${app.home}${/}*">
>         <permission class="java.io.FilePermission"
>                     target="${/}*"
>                     action="read,write" />
>      </grant>

That looks correct.

> This resulted in "Failed to create permission java.io.FilePermission" upon
> Phoenix startup. What is the correct way to set permission for my app to
> access (read, write) files inside app.home?

Looks like a bug - I will look into it. Could you add an entry on Bugzilla
bug
tracking software for this?

--
Cheers,

Peter Donald


--
To unsubscribe, e-mail:
<mailto:avalon-phoenix-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:avalon-phoenix-dev-help@jakarta.apache.org>





--
To unsubscribe, e-mail:   <mailto:avalon-phoenix-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:avalon-phoenix-dev-help@jakarta.apache.org>


Mime
View raw message