avalon-phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jörg Bauer/Denic" <ba...@denic.de>
Subject Re: Re: Problems with undeploy
Date Fri, 22 Feb 2002 11:59:05 GMT
On 22.02.2002 09:45 Peter Donald <peter@apache.org> wrote:
> 
> Hi,
> 
> I am redirecting this to the avalon-phoenix-dev@jakarta.apache.org list. 
Any
> follow ups should go there.
> 
> I fixed the bug - it was a stuuuuupid bug on my part. Thansk for 
reporting it.

;-)

Thank you....
Another point:
ClassLoader issue. 
Here is the test:
start phoenix using avalon-demo.sar from cornerstone
make request to 8999 and get:
>Hello World!
>Requests so far = 1
>you are thispc on 127.0.0.1
 
now undeploy avalon-demo, and redeploy it

again request to 8999:
>Hello World!
>Requests so far = 2                            <-- here is the problem
>you are thispc on 127.0.0.1
 
I would expect that the new avalon-demo is running in a new ClassLoader 
environment with a fresh loaded class. 
Why not ???
I´m no expert with all this classloading stuff, but could you give me a 
hint where to look for the solution ???

-- 
----------------------------------+-------------------------------------------
Joerg Bauer                       | eMail : Joerg.Bauer@denic.de
DENIC eG                          | Fon   : +49 69 272 35 180 
Wiesenhuettenplatz 26             | Fax   : +49 69 272 35 235
D-60329 Frankfurt                 |
----------------------------------+-------------------------------------------

--
To unsubscribe, e-mail:   <mailto:avalon-phoenix-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:avalon-phoenix-dev-help@jakarta.apache.org>


Mime
View raw message