avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen McConnell <mcconn...@apache.org>
Subject Re: repository
Date Wed, 26 Nov 2003 00:01:48 GMT


Peter Courcoux wrote:

>I have the following in my merlin user repository :-
>
>         <resource id="commons-jelly-tags-define" version="SNAPSHOT"/> 
>         <resource id="commons-jelly-tags-bsf" version="SNAPSHOT"/>
>
>Both these files seem to reside in maven under group commons-jelly and
>are not found when starting up merlin.
>
>What is the correct format for this?
>

The format is fine.

>Cause: java.lang.Exception
>Message: Unable to locate resource from which to load info for component implemented by
class "{0}".
>
There are two issues here:

1. your missing the <classname>.xinfo files (did you run avalon:meta and 
the xinfo files included in the jar)
2. a minimor bug in the meta package that was not providing the 
classname (thats why you see {0}) but that's been fixed and committed

Steve.

-- 

Stephen J. McConnell
mailto:mcconnell@apache.org

|------------------------------------------------|
| Magic by Merlin                                |
| Production by Avalon                           |
|                                                |
| http://avalon.apache.org/merlin                |
| http://dpml.net/                               |
|------------------------------------------------|





---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@avalon.apache.org
For additional commands, e-mail: dev-help@avalon.apache.org


Mime
View raw message