avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexis Agahi <a...@users.sf.net>
Subject [Merlin] Did something change in composition (since 3.1)
Date Mon, 10 Nov 2003 17:44:02 GMT
Hi,

Using current Merlin CVS (build successfull), when trying to run an 
application (with composition), I get a "java.lang.NoClassDefFoundError".

Did something change in composition?
(as always: on Linox OS)

Regards


---------------------------------------------------------------

Al@five:~/openim> ./openim.sh
Setting OPENIM_HOME: /home/Al/openim

RUN CMD IS: /home/Al/works/merlin-bin/bin/merlin.sh 
/home/Al/.maven/repository/openim/jars/openim-server-impl-1.1.1.jar -config 
/home/Al/openim/conf/config.xml -home /home/Al/openim

RUN CMD IS: /usr/local/jdk/bin/java 
-Djava.security.policy=/home/Al/works/merlin-bin/bin/security.policy 
-Dmerlin.home=/home/Al/works/merlin-bin 
-Djava.ext.dirs=/home/Al/works/merlin-bin/ext -jar 
/home/Al/works/merlin-bin/bin/lib/merlin-bootstrap-1.0.jar 
/home/Al/.maven/repository/openim/jars/openim-server-impl-1.1.1.jar -config 
/home/Al/openim/conf/config.xml -home /home/Al/openim

[INFO   ] (kernel): installing: 
file:/home/Al/.maven/repository/openim/jars/openim-server-impl-1.1.1.jar
Composition failure.


---- report -------------------------------------------------------

Exception: java.lang.NoClassDefFoundError
Message: org/apache/avalon/activation/appliance/impl/DefaultBlock

-------------------------------------------------------------------


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@avalon.apache.org
For additional commands, e-mail: dev-help@avalon.apache.org


Mime
View raw message