avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filip Defoort <fi...@cirquedigital.com>
Subject Re: merlin tutorials - BLOCK-INF missing
Date Tue, 21 Oct 2003 23:22:53 GMT
Hi Stephen,

Maven -v says "v1.0-rc1-SNAPSHOT"

It does seem to dump some exceptions in maven.log:
java.lang.NumberFormatException: For input string "includes"
(looks like it has issues parsing the <resource> stuff)

Thanks,
- Filip

Stephen McConnell wrote:

>
>
>
> Filip Defoort wrote:
>
>> Hi,
>>
>> I'm trying to run the merlin 3.2 tutorials, and following the 
>> instructions in
>> the readme, do a "maven" and a "merlin target/classes -execute", but 
>> it turns
>> out that the block.xml is not being copied into a BLOCK-INF/ directory,
>> neither directly under target/classes nor into the jar.
>> Easy to workaround and put it there manually, but I'm wondering what's
>> going on.. Pretty much all the tutorials seem to exhibit this 
>> behaviour...
>>
>> Anybody any ideas? 
>
>
>
> It's working here ...
>
> $ cd tutorial\hello
> $ maven
> $ merlin target\classes -execute
>
> The actual instructions for the copying of the block.xml are in the 
> tutorial/project.xml file.
>
>      <resource>
>        <directory>${basedir}/conf</directory>
>        <targetPath>BLOCK-INF</targetPath>
>        <includes>
>          <include>block.xml</include>
>        </includes>
>      </resource>
>
> So everything should be working just fine.
>
> Which version of maven are you running?
> (I'm using maven 10)
>
> Steve.
>
>>
>>
>> - Filip
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@avalon.apache.org
>> For additional commands, e-mail: dev-help@avalon.apache.org
>>
>>
>



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@avalon.apache.org
For additional commands, e-mail: dev-help@avalon.apache.org


Mime
View raw message