avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 21106] - IllegalArgumentException in Extension.getSpecificationVersion()
Date Sun, 28 Sep 2003 15:14:07 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=21106>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=21106

IllegalArgumentException in Extension.getSpecificationVersion()

mcconnell@apache.org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |INVALID



------- Additional Comments From mcconnell@apache.org  2003-09-28 15:14 -------
A specification version declared in a jar manifest must be in the form of a 
dewy decimal.  In the case of the example presented - the error is generated as 
a result of a non-dewey version declaration.  Manifest declarations in Xerces 
2.4 show dewey decimal versions as do manifest declarations under the xml-apis-
2.0.2. I'm closing this bug report on the grounds that (a) it is not a bug but 
a correct report of an invalid version spec, and (b) recent xerces releases 
appear to have addressed this.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@avalon.apache.org
For additional commands, e-mail: dev-help@avalon.apache.org


Mime
View raw message