avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Courcoux <pe...@courcoux.biz>
Subject Re: Building meta
Date Fri, 12 Sep 2003 12:44:20 GMT
On Fri, 2003-09-12 at 13:41, Stephen McConnell wrote:
> Peter Courcoux wrote:
> 
> >Steve,
> >
> >Needs adding to :
> >
> >avalon-sandbox/meta/project.xml
> >
> 
> This doesn't need dependencies because it doesn't build anything 
> directly. In order to know which project.xml, I need to know which goal 
> failed.

Mmm. When I added the dependency in it built. I'll remove it and see
what happens. Does maven inherit dependencies?
> 
> Steve.
> 
> >
> >Regards,
> >
> >Peter
> >
> >On Fri, 2003-09-12 at 13:30, Stephen McConnell wrote:
> >  
> >
> >>Peter:
> >>
> >>The impl, tools, and plugin project.xml files already contain the following:
> >>
> >>    <!-- pre JDK 1.4 dependencies -->
> >>
> >>    <dependency>
> >>      <id>xml-apis</id>
> >>      <version>2.0.2</version>
> >>    </dependency>
> >>    <dependency>
> >>      <groupId>xml-apis</groupId>
> >>      <artifactId>xmlParserAPIs</artifactId>
> >>      <version>2.0.2</version>
> >>    </dependency>
> >>    <dependency>
> >>      <id>xerces</id>
> >>      <version>2.4.0</version>
> >>    </dependency>
> >>
> >>The xmlParserAPIs-2.0.2.jar contains the org.w3c.dom.Node class.
> >>
> >>Can you provide more info about where this error was occuring.
> >>
> >>Steve.
> >>
> >>
> >>Peter Courcoux wrote:
> >>
> >>    
> >>
> >>>Berin,
> >>>
> >>>Thanks. I now have merlin tutorials running. Would it make sense to add
> >>>the dependencies into the project.xml file in a commented block for
> >>>those of us who are still on 1.3.1?
> >>>
> >>>Regards,
> >>>
> >>>Peter
> >>>
> >>>
> >>>
> >>>On Thu, 2003-09-11 at 22:01, Berin Loritsch wrote:
> >>> 
> >>>
> >>>      
> >>>
> >>>>Peter Courcoux wrote:
> >>>>
> >>>>   
> >>>>
> >>>>        
> >>>>
> >>>>>Hi all,
> >>>>>
> >>>>>I'm getting test failures building avalon-sandbox/meta
> >>>>>
> >>>>>NoClassDefFoundError : org.w3c.dom.Node
> >>>>>
> >>>>>Is this a jdk1.3 v jdk1.4 issue.
> >>>>>
> >>>>>I'm compiling with jdk 1.3.1
> >>>>>
> >>>>>If so is the correct answer to add the required jars to the project.xml
> >>>>>dependency list?
> >>>>>
> >>>>>Or am I missing something?
> >>>>>     
> >>>>>
> >>>>>          
> >>>>>
> >>>>:) I believe so.
> >>>>   
> >>>>
> >>>>        
> >>>>
-- 
Peter Courcoux <peter@courcoux.biz>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@avalon.apache.org
For additional commands, e-mail: dev-help@avalon.apache.org


Mime
View raw message