avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Leif Mortenson <leifli...@tanukisoftware.com>
Subject Re: Conflicts in sourceresolve
Date Tue, 15 Jul 2003 05:14:38 GMT
Ok, then maybe this isn't completely me being stupid then. :-) (Maybe)
I have been trying to get Avalon-framework and Fortress to build and
have not
had much success since it was Mavenized.

I have downloaded and installed Maven 1.0b9 and from what I can tell it
is working
correctly.
Running "maven" from within the avalon/buildsystem directory I get a
rather long
document... From within that there is a note about downloading and
installing the
maven-forrest-plugin. Did that and put it into the maven plugins directory.

When I then run "maven avalon:jars", I get the following output:
---
<snip>
Starting the reactor...
Our processing order:
Avalon Build System
Avalon-Framework
+----------------------------------------
| Excalibur is building jar: Avalon Build System
| Memory: 2M/3M
+----------------------------------------

BUILD FAILED
Goal [java:compile] has no action definition.
Total time: 10 seconds
---

The README.txt file in the avalon root dir mentions that I also need to
install
the avalon-buildsystem module. This may be a cause of my problems, but I
can't seem to locate where to download it from.

Any ideas where to proceed?

Thanks in advance,
Leif

peter@realityforge.org wrote:

>>There are also some problems with the new Mavenization of Framework and
>>the knock on consequences for Excalibur. Many default.properties files
>>name a relative target directory for the framework jar, but the jar does
>>not exist. Not a problem for users who remain in IDEs.
>>    
>>
>
>yep - Large chunks of excalibur have not been building for a bit.
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: dev-unsubscribe@avalon.apache.org
>For additional commands, e-mail: dev-help@avalon.apache.org
>
>
>  
>

Mime
View raw message