avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Leo Simons <leosim...@apache.org>
Subject Re: Maven and Forrest
Date Thu, 19 Jun 2003 17:51:00 GMT
Berin Loritsch wrote:
> I am having the hardest time getting Maven and Forrest to work together.
> The plugin is not installing cleanly.  Any tips will be appreciated.
> 
> I also can't run Forrest by itself without the proper "Forrest"
> artifacts where the command line expects them.
> 
> Can I get a little help on this?  A pointer in the right direction?

sure, but first some more information would be a good idea, like what 
environment you're using, what versions of what tools you installed in 
what location, what errors you're seeing, y'know, the usual ;)

the easiest way to start is to copy the file from

http://lsd.student.utwente.nl/repository/forrest/jars/maven-forrest-plugin-1.1.jar

to $MAVEN_HOME/plugins and $MAVEN_HOME/repository,

then remove *.cache from both directories, as well as any 
maven-forrest-plugin* files that may have existed previously. Then cd to 
  avalon/framework and run `maven forrest:generate`.

wrt running forrest itself, you will need something more recent than the 
latest release, for example latest from cvs should work.

cheers,

- LSD



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@avalon.apache.org
For additional commands, e-mail: dev-help@avalon.apache.org


Mime
View raw message