avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Noel J. Bergman" <n...@devtech.com>
Subject RE: James incompatible with Phoenix 4.0.4
Date Wed, 07 May 2003 01:02:08 GMT
Rami,

The Avalon folks are in the process of re-packaging things for a coordinated
release.  I would not attempt to use a mixed set of packages.

Meanwhile, I'll CC the Avalon folks to see if this is an expected
intra-versioning issue.

-----Original Message-----
From: Rami Ojares [mailto:rami.ojares@legosoft.net]
Sent: Tuesday, May 06, 2003 10:51
To: james-dev@jakarta.apache.org
Subject: James incompatible with Phoenix 4.0.4


It seems to me that the update
> Excalibur-Thread upgraded to 1.1
makes James unable to start.
It gives an error like this
> java.lang.NoSuchMethodError:
org.apache.avalon.excalibur.thread.ThreadPool.execute(Ljava/lang/Runnable;)L
org/apache/avalon/excalibur/thread/ThreadControl;

Shouldn't Phoenix have some facilities for version management?
Could these be used so that a non developer would see incompatibilities
more easy.

- rami.ojares


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@avalon.apache.org
For additional commands, e-mail: dev-help@avalon.apache.org


Mime
View raw message